Basiskonfiguration eines CISCO-Routers

Basiskonfiguration eines CISCO-Routers
4.6 (92.5%) 8 gesamt

Die Cisco Router werden als sehr zuverlässige Router angesehen. Es ist schon klar, dass jede Hardware Bugs enthalten und Probleme machen kann, es ist jedoch fast immer möglich mit Firmware Updates dieses Problem zu lösen oder mit bestimmten Tricks zu umgehen. Die Befehle von Cisco Routern sind ziemlich einheitlich – in der Regel sind die Befehle für bestimmte Funktionen bei allen Modellen gleich, was die Konfiguration und die Migration der Einstellungen einfacher macht.

Hinweis: Bei der Konfiguration von VLANs auf Cisco Geräten sollte man aber berücksichtigen, dass die Switche und Router in der Einrichtung einige Unterschiede aufweisen. Die Einrichtung der VLANs ist aber nicht das Thema dieses Beitrags.

Szenario:

LAN: 192.168.1.0/24 ——- Cisco Router———- WAN:10.10.10.0/30 [ FastEthernet Leitung zum ISP Router]

LAN Ip vom Cisco Router: 192.168.1.1/24
WAN Ip vom Cisco Router: 10.10.10.2/30
Ip Adresse vom ISP Router: 10.10.10.1/30

In diesem Artikel werden folgende Schritte durchgeführt:

  • Löschen der bestehenden Konfiguration
  • Setzen eines Passworts
  • Konfiguration von FastEthernet Interfaces
  • Gateway definieren
  • PAT (Port Address Translation) einrichten

Die aktuelle Konfiguration löschen:

Wenn Sie einen gebrauchten Router z.B. bei eBay gekauft haben, solltest du zuerst die alte Konfiguration löschen.

enable
erase startup-config
reload

Ein Passwort setzen:

enable
conf terminal
service password-encryption
enable secret meinpasswort
username ciscoadminprivilege 15 password meinpasswort

FastEthernet Interfaces konfigurieren:

Damit der Router mit Maschinen aus LAN und WAN kommunizieren kann, ist die Konfiguration von LAN und WAN FastEthernet Interfaces notwendig. Daher müssen IP Adressen vergeben werden.

Damit PAT funktioniert (siehe Schritt „PAT einrichten“), muss man „ip nat inside“ beiminternen und „ip nat outside“ beimexternen Interface bezeichnen.

interface fastEthernet 0/0
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shutdown
interface fastEthernet 0/1
description WAN
ip address 10.10.10.2 255.255.255.252
ip nat outside
no shutdown

Gateway definieren:

ip route 0.0.0.0 0.0.0.0 10.10.10.1

PAT einrichten:

Damit die Rechner aus LAN ins Internet gehen können, müssen private IP Adressen „genattet“ werden.

ip nat inside source list 13 interface FastEthernet0/1 overload
access-list 13 permit 192.168.1.0 0.0.0.255

Beim Angeben eines Netzes in access-list, dessen IP Adressen „genattet“ werden müssen, darf man nicht die Subnetzmaske sondern ein Cisco Wildcard angeben: 0.0.0.255

Die Konfiguration speichern:

exit
write memory

Wenn danach die Meldung „Building configuration… [OK]“ erscheint, ist die Konfiguration erfolgreich gespeichert worden.

Wichtig: Falls du deinen Cisco Router wirklich mit dem Internet verbinden möchten, ist es sehr empfehlenswert, die Firewall Funktion (cisco access control lists) auf dem Router einzurichten. Ansonsten, könnte man große Probleme haben, wenn der Router geknackt wird.


In Kooperation mit itslot.de.



Ein Kommentar zu “Basiskonfiguration eines CISCO-Routers

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.